distributed_cache_alignment
仅在 ClickHouse Cloud 中生效。此设置仅用于测试,请勿更改distributed_cache_bypass_connection_pool
仅在 ClickHouse Cloud 中生效。允许绕过分布式缓存连接池。distributed_cache_client_id
仅在 ClickHouse Cloud 中生效。此设置仅用于 CI 测试:非空时,会覆盖 registry 中为该查询请求配置的分布式缓存客户端 ID。它使测试能够将数据分布在一组数量有限的客户端 ID 上,同时确保相同的数据始终位于同一客户端 ID 上。要求在分布式缓存客户端配置中启用ci_mode:如果未启用 (默认情况,例如在生产环境中) ,通过分布式缓存路由读写的查询将以 SUPPORT_IS_DISABLED 失败,而不会静默回退到已配置的客户端 ID。从不访问分布式缓存的查询不受影响,因此会忽略此值。
distributed_cache_connect_backoff_max_ms
仅在 ClickHouse Cloud 中生效。分布式缓存创建连接时的最大退避毫秒数。distributed_cache_connect_backoff_min_ms
仅在 ClickHouse Cloud 中生效。分布式缓存创建连接时的最小退避毫秒数。distributed_cache_connect_max_tries
仅在 ClickHouse Cloud 中生效。连接分布式缓存失败时的重试次数distributed_cache_connect_timeout_ms
仅在 ClickHouse Cloud 中生效。连接到 Distributed Cache 服务器时的连接超时。distributed_cache_credentials_refresh_period_seconds
仅在 ClickHouse Cloud 中生效。凭证刷新周期。distributed_cache_data_packet_ack_window
仅在 ClickHouse Cloud 中生效。用于在单个分布式缓存读取请求中为 DataPacket 序列发送 ACK 的窗口大小distributed_cache_discard_connection_if_unread_data
仅在 ClickHouse Cloud 中生效。如果存在未读取的数据,则断开连接。distributed_cache_fetch_metrics_only_from_current_az
仅在 ClickHouse Cloud 中生效。在 system.distributed_cache_metrics 和 system.distributed_cache_events 中,仅从当前可用区拉取指标。distributed_cache_file_cache_name
仅在 ClickHouse Cloud 中生效。此设置仅用于 CI 测试,用于指定分布式缓存使用的文件系统缓存名称。distributed_cache_log_mode
仅在 ClickHouse Cloud 中生效。用于写入 system.distributed_cache_log 的模式distributed_cache_max_unacked_inflight_packets
仅在 ClickHouse Cloud 中生效。单个分布式缓存读取请求中处于传输中的未确认数据包的最大数量distributed_cache_min_bytes_for_seek
仅在 ClickHouse Cloud 中生效。分布式缓存中执行寻道的最小字节数。distributed_cache_min_inflight_bytes_to_discard_connection_on_seek
仅在 ClickHouse Cloud 中有效。当从已打开的分布式缓存 stream 的当前位置寻道至其他位置时,如果为继续通过读取范围 ID 机制重用连接而需丢弃的预估在传输中的字节数超过此值,则会丢弃该连接并新建连接。这样可避免在频繁寻道时排空大量未使用的数据。设为 0 可禁用此功能,并始终重用连接。distributed_cache_pool_behaviour_on_limit
仅在 ClickHouse Cloud 中生效。用于指定分布式缓存连接在达到连接池限制时的行为distributed_cache_prefer_bigger_buffer_size
仅在 ClickHouse Cloud 中有效。与 filesystem_cache_prefer_bigger_buffer_size 相同,但适用于分布式缓存。distributed_cache_read_only_from_current_az
仅在 ClickHouse Cloud 中生效。允许只从当前可用区读取数据。若禁用,则会从所有可用区中的所有缓存服务器读取。distributed_cache_read_request_max_tries
仅在 ClickHouse Cloud 中生效。分布式缓存读取请求失败时的最大重试次数distributed_cache_receive_response_wait_milliseconds
仅在 ClickHouse Cloud 中生效。从分布式缓存接收请求数据的等待时间 (毫秒) 。distributed_cache_receive_timeout_milliseconds
仅在 ClickHouse Cloud 中生效。以毫秒为单位,表示从分布式缓存接收任意类型响应的等待时间。 Cloud 默认值:20000。
distributed_cache_receive_timeout_ms
仅在 ClickHouse Cloud 中生效。该设置表示从 Distributed Cache 服务器接收数据的超时时间,单位为毫秒。如果在此时间间隔内未接收到任何字节,则会抛出异常。distributed_cache_registry_show_certificate_and_signature
仅在 ClickHouse Cloud 中生效。显示system.distributed_cache_registry 表中的 certificate 和 signature 列。默认情况下,这些列为空,以保持输出简洁;启用此设置可查看其内容。